Jump to content
AC Tool Forums
Sign in to follow this  
bobisbob

My game freezes when i start the script

Recommended Posts

I'm on Windows 10, and my game The Lord of The Rings Online, freezes everytime i start the program.

I did not have this issue when i was using windows 7, anyone have any ideas?

I've attached a picture and script.1

Thanks.
 

Quote

SetActiveWindow 1234
Commanddelay 10
ObjVar 10

Procedure ComboItUP
keydown 1 1 sec
KeyDown ] 1 sec
keydown 2 1 sec
KeyDown 3 1 sec
KeyDown 4 1 sec
KeyDown ] 1 sec
KeyDown 5 2 sec
KeyDown 8 1 sec
KeyDown 9 1 sec
KeyDown ] 1 sec

 

end


while 1=1
call ComboItUP
end


 

freezing.bmp

Edited by bobisbob
tags

Share this post


Link to post
Share on other sites

Is game on admin rights and is ACTools on admin rights?

This does not look like the full macro. if it is, no need for ObjVar to be there at all.

Share this post


Link to post
Share on other sites

What version of ACTools?

Some games will not allow a third party program to run that hooks into the game.

Share this post


Link to post
Share on other sites
33 minutes ago, Ego said:

What version of ACTools?

Some games will not allow a third party program to run that hooks into the game.

latest.

 

 

9 hours ago, Ego said:

Is game on admin rights and is ACTools on admin rights?

This does not look like the full macro. if it is, no need for ObjVar to be there at all.

did admin, also i tried removing the ObjVar line and still same result.

Share this post


Link to post
Share on other sites

i decided to try and load one of the premade ones that the program came in, but deleted alot of the lines and simplied it to the ones below, works okay, seem it causing a tiny lag.


DELAY 2
Loop 1000
 
  Loop 2
    
    Keys 1
    DELAY 1
    
    Keys ]
    DELAY 1
    
    Keys 2
    DELAY 1
    
    Keys 3
    DELAY 1
    
    
    DELAY 1
  End

End

Share this post


Link to post
Share on other sites

Try delay .5 sec

 

Then work on the .5 and lower it

 

The macro you are using would be a help to help trouble shoot it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and to our Privacy Policy.