Jump to content
  • Sign Up
Sign in to follow this  
The WABBIT

AC Tool new Feature/Command request thread.

Recommended Posts

Windows 10, lol.

 

Not gonna catch me on W10 as I still use W7 just fine though it is getting long in the tooth but I can still do without W10.  Maybe W11 if they get enough court cases on them like the one in CA they paid the woman 10k dollars for forcing her to upgrade without her consent.

Share this post


Link to post
Share on other sites

@ DaMON

 

I agree, I do not use W10, nor did I use W8. I'm staying with W7 till Micro$ucks stops this BS about a Computer OS has to look and act the same as the OS they use in a tablet or smart phone.

 

 

 

@ mysticdrew

 

As for the AC Tool working better with W10. At the moment I don't think there is going to be such a thing, at least not completely. The current AC Tool is a 32bit program that requires the use of code, and third party components, that was implemented/created way back in the days of Borland Delphi 5. Some of which can no longer be gotten of hold of as they are no longer being developed/supported. While others are now a PAID for code/component that is too expensive for use in a single small project such as AC Tool. Now as to the code used in detection of pixel color or objects. As I had already stated this is not a AC Tool problem. As the code that is used is great for use on a OS that do not have Aero, or has Aero turned off. The problem is that starting with Windows Vista (BOO, HISS, SCREAM, KILL) Micro$ucks had decided to add features that allow the windows to be semi-transparent, and a few other things to make them look snazzy. That is what Micro$ucks calls Aero. It is Aero that is causing all of the problems. While Aero is turned on, a behind the scenes program renders all graphical displays before sending it to the graphics card. (This is called the Desktop Windows Manager, dwm.exe.) As such there is now a delay in the sending to and receiving from the graphics card by as little as 100's ms to as much as 1000's of ms. All calls to code that access the screen information goes through dwm.

 

With this in mind the code being used in AC Tool for all color and object tests. Is one that gets the individual pixel(s) from the screen to compare it/them. With Aero turned on and doing a small one pixel check there not much of a speed decrease, at least not one noticeable by most people. But, once you start checking for more than a few pixels such a checking for an object, or running the same color check on a single pixel in rapid succession, then you will start to see major jumps in how long that test will take to complete.

 

I have looked into this over that past eight days. And I have found that there is a few ways that I might able to speed up the detection of objects in the game. But, there is no way to increase the speed of the single pixel color tests. (Especially those tests that are rapid repeating single pixel color tests.) None of the code that I have found have any speed increase benefits for single screen pixel access. NONE!

 

Now here is the rub. From what I am seeing of the code examples that I am finding. The object detection speed fix would require the use of API calls that were not available back in the days of Delphi prior to Delphi 2010. And at the moment the current source code for, and components used by, AC Tool would require more man hours to compile without any errors/warnings than it is worth. As such I have continued the working with AC Tool v5.x in Delphi 7 as I do not have to upgrade any of its code or components just to get it to compile in the newer versions of Delphi.

 

I will continue to look into this to see if I can get the object detection faster in a Windows OS newer than XP, but there is no guarantees. Yet I will make sure it that it gets into 'Divide'.

 

So, for those that have to use a rapid repeating single pixel test. You only have one choice if you want the fastes speed from AC Tool. And that is to turn off Aero.

Share this post


Link to post
Share on other sites

I came across a slight problem in-game, I needed to rightclick dragto to remove a stack of items but dragto is left click.

 

Could LeftDragTo and RightDragTo be added?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...